Shadows on glass

I’ve modeled a gridded canopy that casts a nice shadow, and I want that shadow to be visible (at least faintly) on the glass storefront below. This happens with material type set to Diffuse, Glossy Diffuse, and Plastic. It doesn’t happen with material type set to Glossy, Metal, Specular, Thin Dielectric, Thick Dielectric, and Auto. Diffuse, Glossy Diffuse, and Plastic don’t make good glass. Can I have a glassy material that can receive shadows? Images attached (maybe - 1st-time poster)



Dan

What preset are you using? Try using “Super Realistic Exterior”

I was using AmbientOcclusion.prs
I switched to Super Realistic Exterior, with unexpected results.
The material editor changed when I changed presets, and the one I had built by importing several SU materials is now gone, apparently. Do custom materials get saved as part of the Presets? If I customize materials, should I save a custom Preset to keep those custom materials available? For preset Super Realistic Exterior, all materials seem to get set to type Auto. I expected greater control over details of materials, not every material defaulting to type Auto.

When rendered, the scene was very dark. I set Gain to 5 to correct that.

In preset Super Realistic Exterior, shadows got weird. Shadows from the sun disappeared. The image below shows shadows enabled, Contrast at 1.0, Softness at 0. According to the Help, that should produce all sun shadows, no ambient occlusion, and crisp shadows (have I interpreted the Help correctly?). It seems to have rendered the opposite - all ambient occlusion and no sun shadows:

Here’s the scene rendered with preset AmbientOcclusion.prs, Gain 1.5, Shadow Contrast .5, Shadow Softness .05

…and as for the original question I posted, I’m not sure SketchUp is set up to show shadows cast onto a material with low opacity. Here’s why I say that:

…but AO seems to be able to do that, if material type is Diffuse, Glossy Diffuse, or Plastic, as shown in earlier images above.

Hello Dan, for clarity, please avoid multiple posts. Yes, material settings are saved together with the preset, so you should first select the realistic exterior preset, add your material customizations, and then save it as a new preset. In AmbientOcclusion mode, the shadows are taken from the settings of SketchUp shadows. In Super Realistic mode, the shadows are taken from the environment you are using. By default, the Super Realistic Exterior preset uses an environment that doesn’t cast sharp shadows. If you need sharper shadows, select the Super Realistic Exterior preset and the change the environment to one that has a sun with a clear sky. You can download hdri environments from here: HDRIs • Poly Haven

Thanks Nicola, that’s very useful info. When such detailed info is needed, is this message board the right place to seek answers, rather than the online Help?

If you can’t find the information needed in the online help, it’s best to write here