FluidRay 1.1.2 update integration problems with Rhino V5


#1

Updated to FR 1.1.2 and launching from within Rhino still opens version 1.1.1. How do I get Rhino to run the updated version.


#2

Hi Brian,

Please uninstall all previous versions of FluidRay, and re-install the new FluidRay RT in the default location. Also, make sure Rhino is closed during installation.


#3

I installed the 1.1.2 update without first un-installing 1.1.1

Unistalled software and re-installed software as requested.

The Fluidray.rhp file still reflects a 7/9/2014 date.
Pathway to file looks like this…

C:\Users\BJL\AppData\Roaming\McNeel\Rhinoceros\5.0\Plug-ins\FluidRayRhino (d68d786d-cc6e-437d-a3dc-f8b1d92cf7e3)\2014.6.25.606\FluidRayRhino\Rhino 5.0\x64

Running Fluidray from desktop shortcut runs correct version…

Running Fluidray from within Rhino runs version 1.1.1


#4

Can you please give me a little more infos about your system:
What version of Rhino are you using (x86/x64)?
Is it in the standard installation path?
Is C:\Program Files\Rhinoceros 5 (64-bit)\System\x64\rhiexec.exe present?
You can try the following:

  • Remove the folder C:\Program Files\FluidInteractive
  • Remove the folder C:\Program Files (x86)\FluidInteractive
  • open regedit and remove the key HKEY_LOCAL_MACHINE\SOFTWARE\McNeel\Rhinoceros\5.0x64\Plug-ins\D68D786D-CC6E-437D-A3DC-F8B1D92CF7E3
  • Re-install FluidRay

#5

Running Version “x64”

Using Standard Installation path

Is C:\Program Files\Rhinoceros 5 (64-bit)\System\x64\rhiexec.exe present? YES

I will remove folders and registry key and re-install.


#6

UPDATE
** I completely uninstalled FluidRay and started over from an earlier version with the integration plug-in for Rhino. everything works fine up until version 1.1.2.**

Unless there is something I’ve missed in your description for solving the problem, 1.1.2 does not integrate within Rhino 5.0 x64.


#7

Let’s try to remove all references to the old plugin:
Open regedit, delete the following four keys:

HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\5.0\Plug-Ins\d68d786d-cc6e-437d-a3dc-f8b1d92cf7e3
HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\5.0x64\Plug-Ins\d68d786d-cc6e-437d-a3dc-f8b1d92cf7e3
HKEY_LOCAL_MACHINE\SOFTWARE\McNeel\Rhinoceros\5.0x64\Plug-ins\D68D786D-CC6E-437D-A3DC-F8B1D92CF7E3
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\McNeel\Rhinoceros\5.0\Plug-ins\D68D786D-CC6E-437D-A3DC-F8B1D92CF7E3

Then, delete the following directories in the hard drive (change user name where appropriate):
C:\Program Files\Common Files\McNeel\Rhinoceros\5.0\Plug-ins\FluidRayRhino (d68d786d-cc6e-437d-a3dc-f8b1d92cf7e3)
C:\Program Files (x86)\Common Files\McNeel\Rhinoceros\5.0\Plug-ins\FluidRayRhino (d68d786d-cc6e-437d-a3dc-f8b1d92cf7e3)
C:\Users<user name>\AppData\Roaming\McNeel\Rhinoceros\5.0\Plug-ins\FluidRayRhino (d68d786d-cc6e-437d-a3dc-f8b1d92cf7e3)
C:\Program Files\Rhinoceros 5 (64-bit)\Plug-ins\FluidRayRhino.rhp
all directories inside here: C:\Users<user name>\AppData\Local\McNeel\Rhinoceros\5.0\temp\

If you start Rhino now FluidRayRhino toolbar should be gone.
Close Rhino, launch FluidRay RT 1.1.2 installer, restart Rhino

Edit: we found a bug that might be the cause of the problem. Updated files will be available soon


#8

The integration issue should be fixed now. Please try re-downloading and installing the demo.


#9

Uninstalled all previous versions of FluidRay

Followed regedit and folder removal instructions listed

Installed latest 1.1.2 installer for x64

FluidRay 1.1.2 runs independently just fine…imports Rhino files fine, but from within Rhino the FluidRay Toolbar commands are not recognized by Rhino.

Does FluidRay integrate with Rhino like it did before? Do I have to save out my .3dm file and load into FluidRay using File/open from within FR?


#10

I have the same issue as Brian, in that FluidRay will not work with 64-bit Rhino5 in integration mode. The app will hang and stop responding. I have been in contact with the developer, and am currently rendering in stand alone mode until a proper fix is released.


#11

Standard Uninstall of 1.1.2

No success with Rhino integration and latest Fluid Ray version 1.1.3

Stand alone works fine.


#12

Same issue with Fluid Ray 1.1.3.1 in integration mode. Standalone still working fine.


#13

I support the idea of returning to the plug-in strategy that you had functioning before. That level of interaction between Rhino and FluidRay was really nice!!


#14

Hi Brian,
Did you try installing the plugin FluidRayRhino.rhi that I sent you yesterday?

QUESTION: Did you install Rhino in the standard location C:\Program Files?


#15

Nicola,

I received the fluidrayrt-win64-1.1.3.1.exe file only.

I didn’t receive the .rhi file.

Yes…Installed in standard location.


#16

I’ll re-send you the .rhi file


#17

Please resend the file. Thanks.


#18

Just sent it again, please make sure it didn’t go into the spam folder.


#19

Nicola,

Could you send it to the email listed here in my forum profile. My original email address used in our exchange is being filtered by our IT group so the message is not reaching me. Thanks.


#20

Ok, sent. Let me know how it goes