Functional Problems


#1

I was hoping someone had the same problem and would be able to help me.

I am following your new tutorial with version 3.0 and no matter what I do I can never get my “profile” geometry to show up in Viz. I have tried making the profile a group, a component and neither and I can never ever get anything to show up at all. The syncing of the geometry is so simple there is now way anyone can really screw this up but alas, nothing shows up. I have also tried geometry sync with other types and complexities of geometry but still nothing! ARRRGGGGGAAAA


#2

Hi Tim,
Viz currently is in early beta, it’s possible that it has some problems on particular system configurations. What SketchUp version and operating system are you using?


#3

sketchup 2015, windows 7. it used to work when I installed the first version of Viz but the “get geometry source” started acting up even the last update. Here are the steps I am doing and failing at.

  1. draw a weird line and or shape and make it a component, or group or none at all
  2. Open Viz
  3. hit space bar
  4. access the “geometry source” function
  5. go back to sketch up and select the component, or group or lines
  6. hit “set geometry source” in the Viz tool bar in sketchup
  7. I am prompted by Viz to select the correct geometry source node
  8. I then verify that the correct node is selected and hit ‘ok’

Nothin. Blank empty screen. Could any of this have to do with sketchups zero point and Viz’s zero point? I would guess not because even when I hit ‘zoom all’ in Viz nothing appears

I appreciate your help.

Thanks!


#4

It seems to work on SketchUp 2015 64bit on our machines. Does the “MakeGrid” node work?


#5

I have installed the last version 0.5.0 on Sketchup 2016 64bits OS X 10.11.6 and the plugin doesn’t work, it appears this message in Ruby console:
Error: #<NoMethodError: undefined method start' for VizPro:Module> /Users/Oxer/Library/Application Support/SketchUp 2016/SketchUp/Plugins/VizPro/VizProCore.rb:7:inblock in module:VizPro
SketchUp:1:in call' Error: #<NoMethodError: undefined methodactivate’ for VizPro:Module>
/Users/Oxer/Library/Application Support/SketchUp 2016/SketchUp/Plugins/VizPro/VizProCore.rb:42:in block in <module:VizPro>' SketchUp:1:incall’

The previous version 0.3.0 worked fine with the same configuration.


#6

Do you use SketchUp Pro or SketchUp Make?


#7

We just released a new version of Viz that fixes the Mac issue here


#8

I have installed the 0.6.0 version and the plugin works fine now. Perhaps the letters of the help text would be better in black color.


#9

Thanks for the suggestion, we’ll work on improving the readability


#10

Just updated to version 0.6.1, now the help text is black


#11

Ok, thanks for the update!!