FX & AO : background modification?


#1

In FX + AO, it is impossible to get rid of the background picture: not only one is condemned to have the same background in all projects, but, most of the time, the perspective won’t fit!

Playing with the background color doesn’t do a thing: probably a bug!

The only way I’ve found was to cover the unique background with an “Image from file”: please do something about this!

Thanks.


#2

Hi Romark,
If I’ve understood correctly your issue, you just need to run AmbientOcclusion on the viewport, right click -> Background -> Use Solid Color.
Let me know if it works,

Alberto


#3

Hi Alberto, thank you for your remarks!

Yes, you’re right, but I was talking from an FX point of view: in absence of an User manual, I thought AO can be manipulated from inside FX. In fact, there are two AO: one that comes with the Architecture 2 AO preset in FX, where the background cannot be manipulated, and the basic AO.

Actually, there are several issues…

Regarding AO alone:

  • Changing Backgrounds and Environments only works in SU viewport!?!
    While in AO – separate window, despite the fact that the menus suggest the possibility, it is not possible to change Backgrounds and Environments from here (this is confusing, these menus should be adapted).
  • When downloading Backgrounds pack1 and Environments pack1, they are unzipped somewhere in C:\Users\UserName\Documents\AOEx & \AOPro: shouldn’t they go somewhere more closely related to SU, like C:\Users\UserName\AppData\Roaming\SketchUp\SketchUp 2017\SketchUp\Plugins\AO\etc.?
    (I guess we could move them by hand, but carefully)…

[For my part, I have enriched the AO backgrounds and the FX images with skies and other parks of my own (1600x1067, 300dpi)]…

Regarding the use of AO from inside FX:

  • 1st, one has to prepare AO in SU viewport;
  • Only then can FX take in account background changes (this answers your question).
  • However, solid color backgrounds set in AO alone aren’t taken into account in FX (background stays SU color: in SU, I’ve turned off sky and ground, background to white).
  • To deal with the background issue in FX, I add an Image from file.

In conclusion, AO is a convenient way to change moods of the architectural object before dealing with exteriors and other (graphic) effects in FX: great software!


#4

Hi Romark,
Here you are the links to SketchFX and AmbientOcclusion user manuals (both accessible through SketchUp’s menu):
https://www.fluidinteractive.com/products/sketchup-extensions/sketchfx/help/
http://www.fluidinteractive.com/docs/ambientocclusion/start

We tested setting background and environments from the standalone window without any problem. Please double check that you’ve selected “Use solid color”.

About “Architecture 2 AO preset” and all the other presets with an AmbientOcclusion layer, they use AmbientOcclusion’s settings for background and environment. As stated in my previous message, you can set them running AmbientOcclusion on the viewport, right-click, etc… Then SketchFX will use these settings. In the future, you’ll be able to handle background and environment settings directly from SketchFX.
If you’re still having issues using a solid color as background, it could be dependent on the particular preset you’re using. For example, if you’re checking “use depth as mask”, you’re going to see SU’s background.

One last note: if you wish to share your presets, you can save them from SketchFX’s toolbar and upload them here.
Thanks!

Alberto


#5

Hi Alberto: thanks for your prompt and useful answer!

Yes, I’ll take a closer look at the User manuals…
By the way, the AO one needs a small updating:

It is now possible to select rendering resolution in both Render Viewport and Render Window: great!

As far as changing the video destination file, it didn’t work for me.

Also, didn’t know where to look for “batch rendering”: maybe an extra button, like for video rendering?

I’m also lightening my post above with regard to showing setups: thanks for your suggestion regarding setups exchanges.

Regards,
romark