Import .obj into Sketchup, becomes TOO to reduce?

Hello ALL,
So I have an .obj file (terrain scan) that I am importing into Sketchup. It’s only 300,000 KB, but when I convert it using FluidImporter, it blows up to 1.95 GB and moves way too slow!
Does anyone have a work-around for this, or ran into this problem?
How did you fix it?
Am I missing something in the Import settings?
Thank in advance!!