Importing with Textures causes a crash

Importing models with textures causes Fluidimporter Pro to crash when the viewer window pops up.

I’ve been having this issue for a while, i’m currently using Sketchup 2021, although I have tried older versions of Sketchup as well and they act the same. I’ve also tried my other computer and behavior is the same. Both are on Windows 10.

I’ve also tried using .dae, .obj, .fbx, all kinds of different file formats to no avail, they all appear to be importing correctly at first but then crashing due to some texture bug.

In some cases the issue can be resolved by lowering the texture’s resolution. In my experience you are likely to get this crashing behavior using textures larger than 2048 x 2048, but in some cases, lowering the resolution to 1024 x 1024 or even lower will still not work. I currently have a model with textures that are 800 x 800 and still none will import without a crash.

all of my models are coming from blender, and i’ve tried many different combinations of exporting settings and even different exporters, always the same result. all the textures are currently in png format as well, I will try changing the image formats to jpg and see if that makes a difference.

any help would be appreciated!

Should also mention that I have an RTX 2080 Ti and all graphics drivers are updated to the latest on both machines

and changing the image format to jpg does not resolve the issue, nor does changing Sketchup texture preferences regarding maximum texture size, etc.

also trying in a brand new blank sketchup file does not resolve the issue either

What version of FluidImporter you have installed? You can check int the menu Extension->Extension Manager

sorry for the late response - using version 5.0.6

Can you please send us the file you are trying to import, including the textures? We will test it on our machines.

Sure thing! in the attached zip are a few models, in both .FBX and .DAE formats along with the textures and a .blend source file as well just in case you’d need it.

All of those models are causing this crashing behavior on my machine.

(Sharing via google drive since I hit the max file size)

Thank you in advance for your help!

Thanks for the files, we’ll test it on our machines

We found the bug, the issue will be solved in the upcoming release, FluidImporter 5.0.7

Incredible! Thanks so much for your help, will keep an eye out for that 5.0.7 update :slightly_smiling_face: