New user, problem with some textures

Hello everyone, I’m new to Fluidray, but I have experience in other render apps ( Showcase, KeyShot ).
I really like FluidRay and am considering to subscribe, however, I have a problem with some of the textures. All the materials like metal, glass, paint work really well, but materials that are supposed to have texture such as wood, stones, concrete do nothing but give a color tone. I tried scaling the texture but that doesn’t change anything, I even went as high as 10000x and as low as 0,1, same result.
I might add that I import my scenes as fbx files, perhaps this has something to do with it ?

Any help is appreciated.


Hello Marcos, what modeling application are you using? The most likely cause of the problem is that the exported model is lacking texture coordinates. You need to make sure that your modeling application generates texture coordinates before exporting to FluidRay

Hi Nicola, I create my models in AutoCAD ( BricsCad since a year ). When I export to an fbx file, I get the option to embed the textures, reference to file or copy to file. Embedded is selected as default.
I’m trying with the reference now.

Edit : that doesn’t work either.

Does the auto cad model have materials assigned that include textures? Or you are assigning materials in FluidRay?

I am asigning the materials in FluidRay. The AutoCad model does have some imported parts from Inventor, so that might be causing it as Inventor assigns materials by default. I’ll do a quick test with simple solids to see if that’s the reason.
On the other hand, Showcase and KeyShot don’t have this problem, there I can apply any texture I want ( on the same model I’m using now). But I really would like to get it working in FluidRay as the reimport function is awesome and saves me a lot of time.

Edit : creating a simple model doesn’t work either. I now also specifically selected to not export any materials, but then there simply are no objects in fluidray. When I export all, it detects 2 materials ( which I haven’t assigned at all). I tried a work around in 3DSmax, but then I’m missing parts of the scene. I’m a bit lost now…

Edit 2 : I managed a work around through Sketchup, I can now apply all materials and textures I want !
A bit less convenient of course, but I’ll settle for it.

The problem is caused by the model non having texture coordinates assigned to it. Probably Showcase and KeyShot generate them on the fly if they are missing, while FluidRay expects them to be already included in the imported model. We will add automatic texture generation soon. The reason why SketchUp solves the problem is because it automatically generates texture coordinates if the model is missing them. You could also try the following:

  1. In AutoCad, assign to your model a material from the AutoCad material library that includes a texture. It doesn’t matter which material, as long as it has a texture image. Doing so might cause AutoCad to automatically generate the missing texture coordinates.
  2. Export in .fbx and import in FluidRay

Thank you very much for your help Nicola. I’m currently rendering an amazing scene for one of my customers. Very happy with FluidRay, I’ll get myself a subscription !