Nothing happens?


#1

Installed Extension through Extension Warehouse.

Restarted Sketchup

Click Import, select OBJ file, click Open and… nothing…

Doesn’t show any CPU usage, doesn’t show any errors, nothing at all happens.

Any ideas why it isn’t working?

Mac OSX High Sierra. Macbook Pro. Sketchup 2018 Pro.


#2

Please open the Ruby console with Window->Ruby Console,
then go to Extensions->FluidImporter -> Import.
Do you get any error?


#3

No, I just tried and nothing shows up in the Ruby Console at all. It just stays as an empty white box.


#4

I am having the same issue, same OS & machine. Can’t buy until I can test, devs! Clock is ticking on my trial version…


#5

I’m having the same problems. Nothing happens.


#6

Same here, choose the file… nothing.


#7

SAME here. No luck through Ruby Console. If they don’t fix soon I’ll call Amex and ask for them to cancel this charge. I need this for work NOW.


#8

Same here, with trial version on Windows 10 Pro v1803, 64bit, Sketchup 2018.

Ruby console error says:
Error: #<NoMethodError: undefined method typename' for nil:NilClass> c:/users/nifty/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/su_dynamiccomponents/ruby/dcobservers.rbe:410:inget_version’
c:/users/nifty/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/su_dynamiccomponents/ruby/dcobservers.rbe:433:in get_class_by_version' c:/users/nifty/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/su_dynamiccomponents/ruby/dcobservers.rbe:648:inblock in onToolStateChanged’
c:/users/nifty/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/su_dynamiccomponents/ruby/dcobservers.rbe:644:in each' c:/users/nifty/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/su_dynamiccomponents/ruby/dcobservers.rbe:644:inonToolStateChanged’


#11

It might be caused by a conflict with some other extension. Please try the following:

  1. go to the SketchUp Extension Manager and disable all extensions but FluidImporter
  2. restart SketchUp
  3. try importing with FluidImporter

#12

Ya…paid for the pro version, deactivated all other plugins, tried everything listed here…even the email doesn’t contain the information needed to fully install. ill be canceling this payment with my credit card…too bad. Wouldve been a great product if it worked…


#13

Hello David,

Did you receive the purchase confirmation email with the USER ID, PASSWORD and ORDER ID? If not, please contact support directly:

https://www.fluidinteractive.com/products/sketchup-extensions/fluidimporter/contact/